1с как сделать прозрачный фон картинки
Перейти к содержимому

1с как сделать прозрачный фон картинки

  • автор:

Как подготовить печать и подпись для добавления в печатную форму (прозрачный фон)

В следующем видео показано как сделать прозрачным фон у изображений. Это может пригодиться, когда вам нужно добавить в печатную форму штамп, логотип или подпись-факсимиле так, чтобы непрозрачный фон картинки не закрывал текст и другие элементы формы.

Прозрачный фон делается с помощью бесплатного графического редактора Paint.net.

Еще обработки и статьи:

Обработка 1С, программа 1С, статья

Как обновить 1С (8.3) самостоятельно (Инструкция)

Обработка 1С, программа 1С, статья

Как узнать версию конфигурации 1С (Номер релиза конфигурации 1С)

Обработка 1С, программа 1С, статья

Как подключить внешнюю печатную форму в 1С 8.2

Обработка 1С, программа 1С, статья

Как изменить текст во внешней печатной форме 1С 8.2

Обработка 1С, программа 1С, статья

Где в 1С Бухгалтерия 8.3 дата запрета редактирования (1С: Бухгалтерия предприятия 3.0)

1с как сделать прозрачный фон картинки

Подскажите как сделать прозрачный фон картинки, сделанной в редакторе самой 1С. 8.2 конверирует картинку в png. Как после это убрать фон.

В редакторе при выборе цвета можно указать полную прозрачность. Только при попытке заливки таким цветом у меня 8.2 уходила в ступор.
Я предпочитаю редактировать и сохранять сразу в png в других редакторах.

(2) А где указать полную прозрачность?
http://icofx.ro/ — этого мне хватает.
ОК. спс. Попробую.

(4) Два раза щелкаешь на цвет в палитре. В числовых параметрах есть прозрачность. Выставляешь в 0 (т.е. по логике это наоборот _не_прозрачность, но пофиг).

(5) просьба.. у меня ссылка распознается, как содержащая MP3, и говорит, что оно «при основной работе Вам не нужно».. заблокировано.

несложно намылить этот редактор мне? мыло — в личке..

1с как сделать прозрачный фон картинки

Добро пожаловать, Гость. Пожалуйста Войдите или Регистрация
Новости:

Наверх

1С++ users forum › 1С++ и прочие расширения v7 › Курилка › Печать: картинка мокрой печати с прозрачным фоном

(Группа Модераторов: 1c++ moderator)

Переключение на Главную СтраницуСтраницы: 1 Отправить Печать
Печать: картинка мокрой печати с прозрачным фоном (число прочтений — 3538 )

Прозрачность фона картинок ТД: что с ней случается при переносе с клиента на сервер и обратно?

Добрый день!
Пытаюсь реализовать программный вывод произвольного количества картинок в определённое место Табличного документа.
Нужно, чтобы фон был прозрачный, то есть, через надписи проступали бы другие элементы табличного документа.
Сами картинки обработал в онлайн-редакторе, чтобы был прозрачный фон. Если вставлять картинки через Конфигуратор в макет ТД, до всё нормально, фон прозрачный. При генерации картинок, всегда выставляю параметр прозрачности в Истина.

&НаКлиенте Процедура ВставитьФаксимиле(Команда) Если не ЗначениеЗаполнено(АдресФайлаФаксимиле) Тогда Сообщить("Выберите пример картинки факсимиле!"); Возврат; КонецЕсли; СодержимоеКартинки = Новый Картинка(АдресФайлаФаксимиле,Истина); ВставитьФаксимилеВТД(СодержимоеКартинки.ПолучитьДвоичныеДанные()); КонецПроцедуры &НаСервере Процедура ВставитьФаксимилеВТД(ДД_Факсимиле,Лево = Неопределено, Верх = Неопределено) СчётчикКартинок = СчётчикКартинок + 1; НоваяФаксимиле = ТабличныйДокумент.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка); НоваяФаксимиле.Картинка = Новый Картинка(ДД_Факсимиле,Истина); НоваяФаксимиле.Линия = Новый Линия(ТипЛинииРисункаТабличногоДокумента.НетЛинии); //НоваяФаксимиле.РазмерКартинки = РазмерКартинки.АвтоРазмер; НоваяФаксимиле.Высота = 10; НоваяФаксимиле.Ширина = 10; НоваяФаксимиле.Имя = "ФаксимилеРазные" + Формат(СчётчикКартинок, "ЧГ="); СтрокаТаблицыФаксимиле = ПечатиИПодписиРазные.Добавить(); СтрокаТаблицыФаксимиле.ПечатьИлиПодпись = ТипФаксимилеРазные; СтрокаТаблицыФаксимиле.ИмяКартинкиВТД = НоваяФаксимиле.Имя; СтрокаТаблицыФаксимиле.СамаКартинка = НоваяФаксимиле.Картинка; СтрокаТаблицыФаксимиле.Координаты = ""; КонецПроцедуры

У меня не отрабатывается прозрачность! Вообще никак! Я пытался создавать картинку из файла на клиенте, чтобы передать её на сервер и в ТД непосредственно, в приведённом примере, конвертирую картинку в двоичные данные и обратно. Также, поскольку в синтаксис-помощнике в статье конструктора объекта типа «картинка» есть фраза

<ПрозрачныйФон>(необязательный)
Тип: Булево.
Определяет, будет ли использован цвет прозрачности при создании картинки.
Используется только для картинок, формат которой не поддерживает прозрачности

.
То я пробовал не использовать второй параметр в конструкторе картинки.
Не прозрачная, и всё тут.
Кто знает, куда девается прозрачность картинок табличного документа, при каком преобразовании это происходит?
С уважением, я.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *