1с унф как убрать номенклатуру в архив
Перейти к содержимому

1с унф как убрать номенклатуру в архив

  • автор:

1с унф как убрать номенклатуру в архив

Дата публикации 18.08.2023

Использован релиз 3.0.5

В документах «Заказ покупателя», «Заказ-наряд» и «Заказ поставщику» можно корректировать состав заказа, сохраняя историю корректировок. Вы можете вычеркнуть определенные строки из заказа, например, если клиент отказался от части товара после его оформления или поставщик не привез товар. Отмененные строки остаются в заказе справочно, но не учитываются в итогах и конечной сумме документа. Такие корректировки позволят завершить работу с заказом, сохранив информацию об отмене для дальнейшего анализа.

Корректировка заказа выполняется следующим образом.

  1. Откройте документ «Заказ покупателя» (раздел CRM / Продажи), «Заказ- наряд» (раздел Работы) или «Заказ поставщику» (раздел Закупки), в который необходимо внести изменения.
  2. В табличной части документа (справа) в колонках «Отменен» и «Причина отмены» установите флажок напротив соответствующего товара, укажите количество и причину отмены. Рис. 1
  3. После записи документа все отмененные товары будут перенесены в таблицу «Отмененные товары, услуги», которая появится ниже. Рис. 2
  4. Чтобы отменить сразу несколько строк документа, перейдите в режим группового редактирования по кнопке «Изменить». Отметьте флажками отменяемые товары, выберите в поле «Что сделать:» команду «Отменить строки». Выберите причину отмены в одноименном поле и нажмите кнопку «Выполнить». Для всех отмеченных строк будет установлен признак «Отменен». Рис. 3
  5. Чтобы отменить все неотгруженные товары в заказе, по кнопке «Заполнить» выберите команду «Отменить неотгруженные строки». Эта операция позволит завершить работу с заказом, если отгрузка по нему больше не планируется. Рис. 4
  6. Для анализа причин исключения товаров из заказа используйте отчеты «Анализ причин отмены заказов покупателей» (раздел Продажи) и «Анализ причин отмены заказов поставщику» (раздел Закупки). Рис. 5

Смотрите также

  • Как в «1С:Рознице» и «1С:УНФ» создать и использовать заказ покупателя?
  • Как в «1С:Рознице» и «1С:УНФ» оформить продажу товаров?
  • Как в «1С:Рознице» и «1С:УНФ» настроить и использовать виды заказов покупателей?
  • Как в «1С:Рознице» и «1С:УНФ» настроить варианты состояния заказа покупателя?

Подпишитесь на новости

Не пропускайте последние новости — подпишитесь
на бесплатную рассылку сайта:

  • десятки экспертов ежедневно мониторят изменения законодательства и судебную практику;
  • рассылка бесплатная, независимо от наличия договора 1С:ИТС;
  • ваш e-mail не передается третьим лицам;

Удаляем номенклатуру в 1С

Часто пользователи 1С встречаются с проблемой неактуальности той или иной номенклатуры, обычно её помечают на удаление и забывают о ней, так как она не участвует в дальнейшей работе. Но что делать если база номенклатуры составляет тысячи или десятки тысяч позиций. В этом случае пометкой на удаление не обойтись и появляется необходимость полного удаления позиций.

Для удаления номенклатуры заходим в раздел «НСИ и администрирование» далее «Номенклатура»

попадаем в раздел, где отражена вся номенклатура

следующим этапом необходимо пометить на удаление те позиции, которые необходимо удалить, для этого на выбранной номенклатуре нажимаем правой кнопкой мыши и выбираем пункт «Пометить на удаление»

после этого у выбранной номенклатуры появиться крестик, который и говорит о том, что данная позиция помечена на удаление

На текущем этапе мы лишь поставили пометку, для полного удаления нам необходимо проделать следующие действия. Для начала необходимо пройти в пункт меню «НСИ и администрирование» далее нажать кнопку «Поддержка и обслуживание»

далее нажать на «Удаление помеченных объектов»

в появившемся окне выбрать способ удаления, это может быть как автоматическое удаление или выборочное, в нашем случае мы выберем автоматическое удаление.

нажать кнопку далее, после непродолжительного времени появиться окно, где будут показаны позиции на удаление

и нажать кнопку «Удалить»

Помните что, после процесса удаления в правом окне появятся документы, на основании которых была введена данная позиция, вам необходимо либо так же пометить данные документы на удаление либо зайти в сам документ и удалить там данную позицию, только после этого позиция удалиться.

После всего вышеописанного, позиция помеченная на удаление исчезнет безвозвратно.

В наше случае, на конечно информационном окне, написано что удалено 3 объекта, это связано с тем, что для полноценного удаления мы удалили так же два документа «Оприходование излишков» и «Установка цен номенклатуры».

Дубли в номенклатуре 1С:УНФ: почему появляются, к чему приводят и как их объединять

Павел Суворов

Павел Суворов Специалист-консультант по УНФ компании «Простые решения», опыт — 1 год.

Часто при работе в 1С:УНФ пользователи сталкиваются с проблемой: дублируется номенклатура товаров. В статье рассмотрим подробно, почему появляются дубли, к каким последствиям приводят, и как их объединять.

Дубли в номенклатуре 1С:УНФ: почему появляются, к чему приводят и как их объединять

Откуда берутся дубли?

  1. Много сотрудников одновременно работают в базе 1С:УНФ, и при этом нет чётких правил и регламентов для работы.
    Например: ваша компания регулярно закупает одинаковые пачки бумаги у двух разных поставщиков. Товар одинаков, но называется у продавцов по-разному. Поэтому при каждой закупке сотрудники создают новую номенклатуру, хотя для компании эта бумага фактически одинаковая. Поэтому для одного товара появляется несколько дублей.
  2. Синхронизация 1С:Управление нашей фирмой и другой программы 1С, например, 1С:Бухгалтерией. Если в двух программах номенклатура одних и тех же товаров называется немного по-разному, в момент синхронизации она продублируется. Так как программа не может сопоставить две отличающиеся номенклатуры.
  3. Если сотрудники работают в 1С:УНФ и 1С:Бухгалтерии предприятия одновременно и создают номенклатуру для одних и тех же товаров в обеих конфигурациях.
  4. Когда номенклатуру загружают в программу из внешних таблиц. Бывает, что в таблицу вместе с новыми товарами внесены и товары, которые уже есть в программе 1С. Они могут не сопоставиться с номенклатурой, и появятся дубли.

К каким последствиям приводят дубли?

Таких последствий может быть несколько:

  • справочники в 1С:УНФ становятся всё больше, увеличивается объем базы. Из-за этого со временем снижается скорость работы.
  • ошибки в отчётности
  • неправильное отображение остатков товаров на складах. Например, вы можете списать товар, который есть в наличии по дублю-номенклатуре. Но фактически на складе товара нет. Так появляются отрицательные остатки — они не позволяют закрыть месяц в программе и отображают неправильную себестоимость товаров.

Как искать и объединять дубли?

Объединяем дубли в списке

Этот способ можно использовать, если дублей немного и вы можете вручную найти и отметить их в справочнике.

Если вы открываете справочник и видите, что несколько номенклатур повторяются с незначительными отличиями, их можно объединить в списке. Для этого находим все дубли, выделяем их и нажимаем на кнопку «Ещё». Откроется список функций — выбираем «Объединить выделенные».

Дубли в номенклатуре 1С:УНФ: почему появляются, к чему приводят и как их объединять

Далее нужно будет определить, какая номенклатура оригинальная, а какие — дубли. Оригинальная номенклатура останется в справочнике и заменит дубли.

Чтобы отделить оригинальную номенклатуру от дубля, нужно выбрать элемент и нажать на кнопку с синей стрелочкой «Отметить как оригинал». Возле этой номенклатуры появится синяя стрелка — значит, эта номенклатура останется в программе. Дубли удалятся из всех справочников и заменятся оригинальной номенклатурой.

Дубли в номенклатуре 1С:УНФ: почему появляются, к чему приводят и как их объединять

Чтобы проверить, где в программе используются дубли, можно нажать на цифру в окошке «Мест использования».

Ищем дубли по номенклатуре

Чтобы найти дубли для определённой номенклатуры, нужно выбрать настройки, по которым программа отберёт дубли.

Чтобы настроить такие критерии, нужно открыть в настройках «Ещё больше возможностей». Нажимаем на вкладку «Общее» — в появившемся окне слева выбираем «Контроль дублей номенклатуры».

Дубли в номенклатуре 1С:УНФ: почему появляются, к чему приводят и как их объединять Дубли в номенклатуре 1С:УНФ: почему появляются, к чему приводят и как их объединять

Отмечаем галочками критерии, по которым система будет искать дубли.

Дубли в номенклатуре 1С:УНФ: почему появляются, к чему приводят и как их объединять

После этого можно проверять номенклатуру — нужно перейти в справочник номенклатуры и выбрать элемент, который будем проверять на дубли. В верхней части экрана нажимаем кнопку «Ещё». Из появившихся функций выбираем проверку на дубли.

Дубли в номенклатуре 1С:УНФ: почему появляются, к чему приводят и как их объединять

Когда проверка закончится, откроется вкладка с информацией о дублях.

Дубли в номенклатуре 1С:УНФ: почему появляются, к чему приводят и как их объединять

Ищем дубли в справочнике номенклатуры

Это самая большая проверка — по справочнику всей номенклатуры.

Чтобы проверить весь справочник, открываем его, нажимаем на кнопку «Ещё» и выбрать функцию для поиска и удаления дублей:

Дубли в номенклатуре 1С:УНФ: почему появляются, к чему приводят и как их объединять

Программа проверит все позиции в справочнике и выявит дублирующиеся — их нужно будет объединить.

Всплывёт окно, в котором нужно будет выбрать условия — по этим условиям программа определит элементы как дубли.

Условия могут быть такими:

Дубли в номенклатуре 1С:УНФ: почему появляются, к чему приводят и как их объединять

  1. «Искать в» — настройка определяет справочник для проверки на дубли
  2. «Отбирать» — можно выбрать отдельные элементы, по которым система не будет искать дубли
  3. «Сравнивать» — эта настройка нужна, чтобы менять условия для поиска: например, можно отменить поиск среди элементов, которые уже помечены на удаление. Или выбрать поиск по похожим словам в наименовании номенклатуры.

Можно добавить новые реквизиты, по которым программа будет искать дубли. Это сделает поиск ещё более тщательным и строгим.

Когда программа закончит поиск, появится список похожей номенклатуры — в ней нужно будет отметить оригиналы. Дубли удалятся.

Искать дубли можно не только в справочниках номенклатуры, но и, например, в справочниках по пользователям, по шаблонам или по контрагентам.

Для этого нужно открыть настройки и перейти в корректировку данных.

Дубли в номенклатуре 1С:УНФ: почему появляются, к чему приводят и как их объединять

Появится функция «Поиск и удаление дублей».

Дубли в номенклатуре 1С:УНФ: почему появляются, к чему приводят и как их объединять

В новом окне выбираем справочник, в котором нужно искать дубли, условия отбора и сравнения. После поиска действия будут такими же, как и в предыдущем случае — выбираем оригиналы, а дубли отмечаем на удаление.

Дубли в номенклатуре 1С:УНФ: почему появляются, к чему приводят и как их объединять

Нужно подобрать программу 1С, оборудование для торговли или готовое решение для автоматизации вашего бизнеса? Проконсультироваться по внедрению или доработкам?

Отправьте заявку на консультацию и партнёр 1С – автор этого материала – вам поможет. Консультация полезная и бесплатная.

Убрать номенклатуру в архив. Поиск в получении данных выбора. Очистка истории выбора.

Возникла тут вот такая задача: убрать старую номенклатуру «в архив», оставить только нужную или загрузить новую. А старую скрыть во всех диалогах.

Фактически эта задача выполняется по таким шагам:

  1. Создается реквизит «Архив» у элемент и групп (в моем случае иерахия элементов, для групп не надо), добавляем его индексирование.
  2. В форму добавляется новый реквизит.
  3. В запрос динамических списков добавляется отбор «Архив =Ложь» или &ПоказыватьАрхивные
  4. Параметр заполняется при открытии формы в ложи или в форму можно добавить реквизит «Показывать архивные».
  5. Можно добавить роль, для которой этот реквизит будет видим либо доступен.
  6. В модуле менеджера спраовчника «Номенклатура» создается обработчик ОбработкаПолученияДанныхВыбора прописывается свой поиск, скорее всего это будет меделенней системного, но пренебрегаем.
    Добавляем раскраску подстроки и ограничиваем список 200 элементами (считаю, что это максимум)

Процедура ОбработкаПолученияДанныхВыбора ( ДанныеВыбора , Параметры , СтандартнаяОбработка )
ДлинаПоиска = СтрДлина ( Параметры . СтрокаПоиска ) ;
Если Параметры . СтрокаПоиска = Неопределено //или ДлинаПоиска
//можно просто до 3 символов сделать стандратнаяобработка=Ложь, тогда не будет искать, это ускорит отбор и выборку
Тогда
Возврат ;
КонецЕсли ;

СтандартнаяОбработка = Ложь ;
Запрос = Новый Запрос ;
Запрос . Текст = «ВЫБРАТЬ РАЗРЕШЕННЫЕ РАЗЛИЧНЫЕ
| Номенклатура.Ссылка,
| Номенклатура.Наименование
|ИЗ
| Справочник.Номенклатура КАК Номенклатура
|ГДЕ Номенклатура.Архив = Ложь
| И Номенклатура.Наименование ПОДОБНО &СтрокаВвода
| « ;

Запрос . УстановитьПараметр ( «СтрокаВвода» , «%» + Параметры . СтрокаПоиска + «%» ) ;

Выборка = Запрос . Выполнить ( ) . Выбрать ( ) ;

ДанныеВыбора = Новый СписокЗначений ( ) ;
ШрифтЖирный = Новый Шрифт ( , , Истина ) ;
Зеленый = Новый Цвет ( 50 , 185 , 50 ) ;
Подстрока = Врег ( Параметры . СтрокаПоиска ) ;
Счетчик = 0 ;
Пока Выборка . Следующий ( ) Цикл
Счетчик = Счетчик + 1 ;

ВрегНаименование = ВРЕГ ( Выборка . Наименование ) ;

ПозПоиска = Найти ( ВрегНаименование , Подстрока ) ;

Если ПозПоиска > 0 Тогда
ФС = Новый Массив ;
Если ПозПоиска < >1 Тогда
ФС . Добавить ( Лев ( Выборка . Наименование , ПозПоиска — 1 ) ) ;
КонецЕсли ;
ФС . Добавить ( Новый ФорматированнаяСтрока ( Параметры . СтрокаПоиска , ШрифтЖирный , Зеленый ) ) ;
ФС . Добавить ( Сред ( Выборка . Наименование , ПозПоиска + ДлинаПоиска ) ) ;
Представление = Новый ФорматированнаяСтрока ( ФС ) ;
ДанныеВыбора . Добавить ( Выборка . Ссылка , Представление ) ;
Иначе
ДанныеВыбора . Добавить ( Выборка . Ссылка , Выборка . Наименование ) ;

Если Счетчик > 200 Тогда
Прервать ;
КонецЕсли ;

Последнее, что остается очистить историю выбора

Оказывается, история выбора хранится в системных настройках, немного экспериментов и получился вот такой код:

Выборка = ХранилищеСистемныхНастроек . Выбрать ( ) ;
Пока Выборка . Следующий ( ) Цикл
Если Выборка . КлючОбъекта = «ИсторияВыбора» Тогда
Массив2 = Новый Массив ;
флЕстьПравки = Ложь ;
Для каждого Эл из Выборка . Настройки Цикл
Значение = Эл . Value ;
Если ТипЗнч ( Значение ) = Тип ( «СправочникСсылка.Номенклатура» ) Тогда
Если Значение . Архив = Ложь Тогда //Проверка архивной записи
Массив2 . Добавить ( Эл ) ;
Иначе
флЕстьПравки = Истина ;
КонецЕсли ;
КонецЕсли ;
КонецЦикла ;
Если флЕстьПравки Тогда
ХранилищеСистемныхНастроек . Сохранить ( Выборка . КлючОбъекта , Выборка . КлючНастроек , Массив2 , Выборка . Представление , Выборка . Пользователь ) ;
КонецЕсли ;
КонецЕсли ;
КонецЦикла ;

Его надо запускать под административныйми правами, что он делает:

  • Перебирает все настройки и если это история выбора, которая хранится в массиве: перебирираются все элементы, и лишние просто не копируются в новый массив.
  • В параметре выбрать, можно сдлеать отбор, но в моем случае это не настолько медленно работает, чтобы имело смысл заморачиваться для однократной процедуры.

Вот и всё: задача почти выполнена.

Остается групповой обработкой поменить ненужные, через обработку загрузки из табличного документа или другим способом загрузить новую номенклатур.

Эту задачу можно было бы решить через ограничения доступа к данным, но не всегда такое возможно: в моем случае это не совсем типовая конфигурация и так было проще и прозрачней, а также интересней в реализации.

Реклама магазина самообслуживания: треска, стоящая в очереди за cобственной печенью.

— Владимир Колечицкий

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *